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Finding Potential Problems - Active Error Checking

Every library has different standards and requirements for its MARC records. The Active Error Checking
feature is designed to help you identify which of your records meet your standards and which still need
cleanup work.

In this tutorial you will learn how to:

Set Active Error Checking options.

+ Use the Active Error checking column in the main window.
+ Use the Active Error Checking panel in the Cataloger.

+ View Active Error Checking details in the Record Viewer.

Import records

If you did not import records in a previous tutorial, proceed with the following steps to import the practice
records into your database. If you already imported records, skip to the next section.

Import the tutorial records
1. Open MARC Magician.

2. Click File and then select Import.

The Import box appears:
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File name: |

Files of bype: |AII Files [.] j Cancel
Help

Batch name: |Eatch 20

Add records o list: |Master List Only j

Click the down-arrow E| to the right of the Look in box, and select C:. In the area underneath the
Look in box, double-click the Program Files folder, double-click the MARC Magician folder, and then
click Tutorial Records.mrc.

3. Click Import.

The import starts. When it is finished, a summary box is displayed with the number of records imported
and a count of the automatic cleanups that were done.
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Setting Active Error Checking options

With your Active Error Checking options, you define which issues you want to be notified about and which
issues you want to ignore. In this exercise you'll set the Active Error Checking options.

Set Active Error Checking options

1. Click the Options button on the toolbar.
The Options dialog box appears.

2. Click the Active Error Checking tab.

S |
Cataloging | Views Active Error Checking | Speling Checker | Templates | Import | Advanced|
Different catalogers have different standards for what they consider “comect” MARC records.

Active Emor Checking helps you ensure that your records meet all of your cataloging standards before
you expoit them. Select what soits of ommisions and mistakes you consider export emors.

Four things are always export emors: & missing lite, too many titles, too many main entries, and fields or
sublields that are too long.

© s

All omissions and emmors are ignored except the four that are always export emmors.

" Texas Library Connection

Records that do not meet the Texas Library Connection requirements cannot be exported. For
all other omissions and enors, you can make your own settings for how the program should

hudaﬂ'mThTmLhuyCurrm that all records have a comect titke, name
ufpl.l:ilhu date of publication, and MdmﬂmThlihn\uﬂrdhendmpﬂm

" Custom...
‘You can make pour own settings for how the program should handle omissions and eors in
records - whether to ignore them, issue wamings, of treat them as export emors.

Show Seltings...

C o] oo | v |

As you can see, there are three levels of error checking: Basic, Texas Library Connection, and Custom.

In this exercise, you will be making Custom settings. If you are curious about Basic and Texas Library
Connection, select Basic or Texas Library Connection, and then click Show Settings.

3. Click Custom.
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The Active Error Checking Settings dialog box appears:

Active Ermor Checking Settings: Custom
Miszing title statement (% always an export emor
Too many main enlries & alwaps an export efror
Too many title statements &+ aways an export emor
Fields ar subfields tan |nl‘lg o) Hways an export emar
Publication mformation:
Mo place  expart enror Wamning " igrore
Mo name € expot emmor warning " ignore
Mo date  expoit efror warning " ignore
Physical description:
Mo extent  exportenor © waming [ & ignore
Mo other phyzical details (" esportenor  { wamning * ignore
Mo dimensions C espotenor © waming \ @ ignore
Controd felds:
Place of public. not set " export efror " igreore
Date not set [ export eror f"' igniore
Running time not et " export enmor " ignore
Mo notes " exportenor  ( wamning * ignore
Mo subjects " esportenor O waming { % ignore
Mo holdings information sxport Ao " waming * ignome
Title in all ypper caze " warning " ignore
Mon-MARL fields or subfields export enor ¢ warhing 1+ ignore
Too many nonqepeatable fields ¢ esportenor ¢ warning % igniore
o subfields
Cacel | Heb |

This dialog box shows all of the possible issues that the program can flag.

For most issues, you can choose one of three options: export error, warning, or ignore. No notification
is provided for issues that are set to ignore. Warnings and export errors are distinguished in various
ways in the main window, the Cataloger, and the Record Viewer. You'll learn more about that later in
this tutorial.

You'll notice that some issues are always export errors. These are serious problems that should always
be corrected. How you set the other issues is for you to decide.

4. For now, make your settings as they appear above, and then click OK.
You return to the Active Error Checking tab.
5. Click OK again to close the Options dialog box and save your settings.

The column - Active Error Checking and the main
window

Now let’s find out whether the records meet our criteria:

Take a look at the Active Error Checking column. Unless you moved it, this is the first column of the record
list. (You might see just the letter A... on the column header, but if you were to resize the column you'd see
the whole title.) This column displays a yellow triangle for records with warnings and a red stop sign for
records with export errors. The column displays a green OK for records with no errors or warnings.
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Sort the records by errors and warnings
1. Click the Active Error Checking column header.

The records that have export errors and warnings should now appear next to each other in the list.

2. Click the column header a second time so that the records with errors and warnings appear at the top

of the list.

Note:

What if a record has issues defined as warnings and issues defined as errors? In
this case, a red stop sign is displayed.

The panel - Active Error Checking and the Cataloger

In this exercise you will find out exactly what is wrong with these records by looking at the Active Error

Checking panel in the Cataloger.

Open some records in the Cataloger

1.

2.

5.

Select a record in the Master List, Freaky People Need Not Apply.

Click the Edit |ﬁ| button on the toolbar.
The record you selected is opened in the Cataloger.

Take a look at the Active Error Checking panel for the record. It should look something like this:

Active Error Checking:

unknown place of pub [control
fields].; upper casze title (245 $a);
no pub. place [260 $a); no pub.
name [260 $b); no pub. date (260
$c)

(If you don't see the Active Error Checking panel, it may be turned off. You can turn it back on again by
opening the View menu and clicking Active Error Checking Panel.)

What the panel tells you is that the place of publication control field has not been set, there is no place
of publication in subfield 260 a, no publisher name in 260 b, no publication date in 260 ¢, and the title
is in upper case. Notice that some of the text is black and some is red. The black text means that we
defined this particular omission as a warning. The red text indicates that we set an upper case title to
be shown as an export error.

To fix the title, move the insertion point to subfield 245 a, delete the title and retype Freaky
people need not apply, this time with correct capitalization.

Notice that the text in the Active Error Checking panel disappears as you type.

To fix the place of publication, move the insertion point to subfield 260 a and type New York.
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8.

Notice that the unknown place of publication (control field) disappears after you type the “k” in New
York. We set that field automatically when we recognize it!

To fix the publisher name, press the Enter key and type Hamster Dance BooOKSin260b.
To fix the publication date, press the Enter key and type 1965 in 260 c.

Save the record and close the Cataloger.

You return to the main window. The record you corrected no longer displays an export error in the Active
Error Checking column.

The details - Active Error Checking and the Record
Viewer

In this exercise, you'll learn how to view detailed information about Active Error Checking issues in the
Record Viewer.

Select records with errors or warnings
First you'll use a command on the Select menu to select only records with errors and warnings.

1.

On the Select menu, click Records with Errors or Warnings.

The following dialog box appears:

Select Records with Errors or Warnings

— Select records with:
" No erors or wamings
" Warnings
" Enors
(5' Either emmors or warrir‘ng:s)

" Title in all upper caze

Cancel | Help |

As you can see, this command gives you several options. In this exercise we want to select just records
that have errors or warnings.

Click Either errors or warnings, and then click Select.

All records with errors or warnings should now be selected in the list.

Open the records in the Record Viewer
Now we'll take a look at these records in the Record Viewer and see how Active Error Checking is handled
there.

e Click the Record Viewer button on the toolbar.

MARC Magician Tutorial 6 - Active Error Checking 6



The selected records are opened in the Record Viewer:

: Record Viewer: Cricket

Control fields MARC codes:
1] 1
.123456789.123456789.123456789.123456789
Type: Serial
Leader: 01077cas-+-2200265-a-4500
007:
008:

Cricket (La Salle, lil))
Cricket

(La Salle)

Cricket

(La Salle)

Cricket.

La Salle, Ill. :

T -

Set Record Viewer options
Next you will learn how to set the View options to show details about the errors and warnings.

1. Click Options.

The Options dialog box appears with the View tab in front:

<17

The Record Viewer options are displayed in the Record viewer section.

2. In order for the Record Viewer to display the Active Error Checking details, the Show Active Error
Checking errors and warnings check box must be selected. This check box is probably already
selected, but if it isn't, select it now, and then click OK.
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The Options dialog box closes and you return to the Record Viewer.

View Active Error Checking details
Details about the errors and warnings for each record are displayed at the bottom of each record. For
example, here's what is displayed for the record titled High-adventure Outdoor Pursuits.

Active Error Checking

YWarning Unknown place of publication in control fields. Enter the city name of the
place of publication. You can enter [S.1] if no information is available

Export error: The title in this record is all upper case (245 5a). Reenter the title in upper
and lower case

YWarning Mo publishers name (260 Sk). You can enter [S.n.] if no information is
available
YWarning IMNo date of publication (260 $c)

If you wanted to edit this record, you could open it in the Cataloger by clicking the Edit button.

Take a look at the Active Error Checking details for the other records. When you're finished, you can close
the Record Viewer.

Close the Record Viewer
e Click Done.

Important:

While Active Error Checking can be a tremendous help in locating potential problems, it is not a
foolproof way of determining the quality of your records. Records that show an OK may have other
problems (such as improper cataloging) that the program doesn’t flag, and records that show export
errors or warnings may actually be correct. For example, if you have Active Error Checking set to flag a
missing publication date, your serials (which usually aren’t supposed to have this subfield) will show
errors or warnings even though they are actually correct.
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Review & practice

In this tutorial you learned how to set Active Error Checking options and find potential problems, and
you learned how Active Error Checking errors and warnings are displayed in the main window, the
Cataloger, and the Record Viewer.

Now you can take a break, practice some more on your own, go right on to the next tutorial, or get to work
on your own records.

Take a break
If you'd like to take a break, on the File menu, click Exit.

Practice some more
Here are some suggestions for practicing on your own:

¢ Play around with different Active Error Checking options.
¢ View errors and warnings in the Cataloger and the Record Viewer.

Go to the next tutorial
If you'd like to jump right in to the next tutorial, stay where you are in the main window. You're all set to
begin the next tutorial. Remember that you can do most of the tutorials in any order you'd like.

Get to work on your own records
If you feel like you don't need any more practice and want to get to work on your own records, you just
need to delete the practice records and you're ready to go:

1. Click Select, and then click All Records.
2. Click Record, and then click Delete from All Lists.

The Master List should now be empty.

6/4/2008
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