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Fixing Up Your Database – Global Editing Basics 

In this tutorial you’ll learn how to edit several records at once. You’ll get your first glimpse of the power and 
flexibility of MARC Magician’s many global editing features. 

 

What is global editing? 
Global editing means editing several records at a time. MARC Magician provides sixteen (count em!) global 
editing commands that you can use to clean up your records: 

 

Now, that’s a lot of commands. 

It’s unlikely that you’ll need to use all of these commands on your own records. You’ll probably find that 
you can get your global editing tasks done using just two or three of these. In this tutorial you’ll learn how 
to do some basic global editing. You’ll be warned about the pitfalls, and you’ll learn how to “hedge your 
bets” by backing up the database. 

In this tutorial you will learn how to: 

• Import records into MARC Magician. 
• Back up the database. 
• Find and replace text in a group of records. 
• Add a field to a group of records. 
• Fix the capitalization of fields or subfields that are all in upper case. 
• Restore the database from a backup. 
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Import records 
If you did not import records in a previous tutorial, proceed with the following steps to import the practice 
records into your database. If you already imported records, skip to the next section. 

Import the tutorial records 
1. Open MARC Magician. 

2. Click File and then select Import. 

The Import box appears: 

 

Click the down-arrow  to the right of the Look in box, and select C:. In the area underneath the 
Look in box, double-click the Program Files folder, double-click the MARC Magician folder, and then 
click Tutorial Records.mrc. 

3. Click Import. 

The import starts. When it is finished, a summary box is displayed with the number of records imported 
and a count of the automatic cleanups that were done. 

Backing up the database 
By default, MARC Magician automatically backs up the database every time you exit the program. When 
you are doing global editing, it’s usually a good idea to back up the database more frequently. In fact, you 
should get in the habit of backing up the database before every global edit. 

In this exercise you’ll back up the database so that if anything goes wrong with the global editing you do in 
the next exercises, you can restore the backup. 

Back up the database 
On the File menu, click Backup Database. 

Whenever a backup is taking place, a progress dialog box appears: 
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Depending on how many records are in your database, backup can take anywhere from less than a second 
to several minutes. 

 

Now you’re all set to begin. 

Finding and replacing text 
The scenario: You’ve discovered that some of the records in your catalog have “Large type books” as a 
subject heading. According to the subject heading authority you use, the preferred term is “Large print 
books.” Perfectionist that you are, you’d like to fix these records. 

In this exercise, you’ll use the Find and Replace global editing command to search the subject headings for 
the incorrect term and replace it with the correct one. 

Find and replace subfield text 
1. On the Select menu, click All Records. 

All of the records in the Master List should now be highlighted. 

2. Click the Global Editing button   on the toolbar, and then click Find and Replace. 

The Find and Replace dialog box appears: 

 

You’ll use the top part of this dialog box (Fields to look in) to restrict the search to only the subject 
fields. You could search all fields, but by restricting the search you ensure that the text won’t 
accidentally be replaced in other parts of the record, where it may actually be correct. 

3. Under Fields to look in, click Selected. 

Tip: 

Here’s a quick way to back up the database by using a keyboard shortcut: Press 
the Ctrl key and hold it down. Press the B key, and then release the Ctrl key. 
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4. Since you only want to find and replace text in subject fields, select the check box next to Subjects. 

5. In the Find what box, type Large type books. 

6. In the Replace with box, type Large print books, and then click OK. 

The program begins searching for the text in the selected records. When the program finds a record 
containing the text you specified, the Make Change dialog box appears: 

 

As you can see, the program has found your text in the 650$a subject heading. The text appears 
highlighted. Under Highlighted text will be changed to, you see the phrase that will replace the 
existing text. 

7. Click Change to change the text in the current record and continue searching. If want to change all the 
records at once, click Change All. This will make the change in every record without any further 
prompting. 

Adding a field 

The Scenario: You want to add a series statement field (440) to a group of books belonging to Carolyn 
Keene’s series The Nancy Drew files. 

Select records 
First you’ll select the all of the records with Keene, Carolyn as a main entry. 

1. On the Select menu, click Records with Certain Text. 
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The Select Records with Certain Text dialog box appears: 

 

2. Under Fields to look in, click Selected. 

3. Click the Main Entries check box. 

4. In the Look for box, type Keene, Carolyn, and then click Select. 

All of the Nancy Drew books should now be selected. 

Add a field 
Next you’ll add a 440 (Series Statement/Added Entry -- Title) field to the selected records. 

1. Click the Global Editing button   on the toolbar, and then click Add Field. 

The Add Field dialog box appears: 

 

2. Click Select to choose the field to add. 

The global editing dialog 
boxes always 
“remember” the last 
settings used, so if the 
Add Field command has 
been used before, the 
dialog box on your 
screen will look different 
from the one in this 
figure. 
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The Select Field dialog box appears: 

 

Like some of the other dialog boxes you’ve worked with in this tutorial, this one allows you to choose 
the field in one of two ways: you can select from the list, or type the field tag directly in the box. 

Since you know the MARC tag of the field you want to add, you’ll type it in the box rather than 
selecting the field from the tree. 

3. Click Select from text box, type 440 in the box, and then click OK. 

You return to the Add Field dialog box. Something has changed: the Subfields area now has a white 
background, and the Add button is no longer dimmed. 

You’ll use this button to choose the subfield (and text) to put into the field. 

4. Click Add. 

The Add Field: Add Subfield dialog box appears: 

 

5. Select the $a (Title) subfield. 

6. Under Text for subfield, type The Nancy Drew files, and then click OK. 

You’re back in the Add Field dialog box. You’ve made all the settings you need, so take the plunge and 
click OK to begin global editing. 
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7. Soon the Make Change dialog box appears: 

 

The top part of the dialog box shows the record as it is now, and the bottom part shows the change 
that will be made. 

8. Click Change to add the field in the current record and continue searching. 

Each time the program finds the specified text, the Make Change dialog box appears. 

9. Review a few more changes to make sure the command is working as intended, and then click Change 
All to change the rest of the selected records. 

When the program is finished editing, the Completed Add Field dialog box appears. It tells you how 
many changes were made in the selected records. Click OK to close this dialog box. 

FIXinG cApITaliZAtiOn 

The scenario: You’ve discovered that some of your records were typed in all upper case letters. Ugh. You 
want to contribute these records to a union database, but they don’t accept records with improper 
capitalization. 

No problem. In this exercise, you’ll use the nifty Fix Capitalization command to clean up those records. The 
capitalization won’t be perfect, but you’ll minimize the number of corrections you have to do by hand. 

Select records 
First select all of the records with a title in all upper case. 

1. On the Select menu, click Records with Errors or Warnings. 

The Select Records with Errors or Warnings dialog box appears: 
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2. Click Title in all upper case, and then click Select. 

The records with all upper case titles are now selected. 

Add selected records to list 
Because you will have to correct some capitalization by hand after you do the global edit, it’s a good idea 
to put these records into a list so you can keep better track of them. 

1. On the List menu, point to Add Selected Records to List, and then click New. 

The New List dialog box appears. 

2. In the Name box, type a name for your list, and then click OK. 

A new list is created. It contains just the upper case records. 

Fix capitalization 
Now you are ready to do the global edit. 

1. On the Select menu, click All Records. 

2. Click the Global Editing button   on the toolbar, and then click Fix Capitalization. 

The Fix Capitalization dialog box appears: 

 

You use this dialog box to define precisely which fields the program should fix. In this example, you 
just want to fix the basic fields. 

3. Click Fix basic fields (all except numbers, holdings, local and custom, fields). 

Near the bottom of the dialog box, you see a check box labeled Check only subfields that are in all 
upper case. Make sure this check box is selected. (You don’t want the program to fix anything that ain’t 
broke.) 
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4. Click OK to start fixing capitalization. 

The Make Change dialog box appears. Notice that the program often suggests the correct 
capitalization – but not always. In this example, it is probably most efficient to let the program go 
ahead and fix all of the capitalization, and then visually check the records in the Record Viewer. You can 
correct the remaining mistakes by hand. 

5. Click Change All to make the change in all of the selected records, without further prompting. 

Review changes in the Record Viewer 
If you like, you can review the changes in the Record Viewer now: 

1. Click the Record Viewer button  on the toolbar. 

2. If you see any errors that need to be fixed, click Edit. 

This will open the Cataloger for the current record. When you are finished editing the record, exit the 
Cataloger to return to the Record Viewer and continue scanning the records. 

3. When you are finished checking the records, click Done to close the Record Viewer. 

Delete the list 
You don’t need to keep these records separate from the rest of the records in the Master List anymore, so 
you can delete the custom list you created. 

1. On the List menu, click Delete Whole List. 

The Delete Whole List dialog box appears. 

After all the work you’ve just done, you don’t want to completely delete the records – you want to 
leave them in the Master List. 

2. Click Keep them in the Master List (and other lists), and then click Delete List. 

3. Click Delete List again. 

Restoring the database 
Even though the global editing (presumably) went well, in this last exercise, for the purpose of 
demonstration, you’ll restore the database from a backup. When you do this, all of the changes you made 
in this tutorial will be reversed. 

• On the File menu, click Restore Database. 
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The Restore Database dialog box appears: 

 

This dialog box shows a number of backup files that you can select from. By default, a backup file is 
created automatically every time you exit the program. You want to select the one you created 
manually at the beginning of this tutorial. The name of the backup file shows the date and time it was 
created, with the following syntax: 

“MARC Magician Backup” followed by the 4-digit year, 2-digit month, 2-digit day, and 6-digit time (hour, 
minute, and second, using a 24-hour clock). 

The most recent one should be at the bottom of the list. 

• Select the most recent backup, and then click Open. 

The database is restored to the way it was at the beginning of this tutorial. 

Caveat Editor! 
Global editing is powerful stuff. You can fix a lot of errors in a very short time – but you can also do a lot of 
damage. Global editing cannot be reversed with the Undo command, so don’t use a global editing 
command on your own records until you fully understand how it works. 

Here are some ways to “hedge your bets:” 

• Practice the command a few times on the practice records before working with your own records. 

• Try the command on a single record first. 

• Always review at least the first four or five changes in the Make Change dialog box before changing all 
of the selected records. 

• Before you do a global editing procedure, open the File menu and click Backup Database. If 
something goes awry, you can use the Restore Database command to go back to the records as they 
were before you did the global edit. 
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Review & practice 
In this tutorial you learned the basics of global editing and how to back up the database and restore from a 
backup. 

Now you can take a break, practice some more on your own, go right on to the next tutorial, or get to work 
on your own records. 

Take a break 
If you’d like to take a break, on the File menu, click Exit. 

Practice some more 
Here are some suggestions for practicing on your own: 

• Practice the global editing commands you learned in this tutorial. 

• Try out some different global editing commands. 

• Look up importing and exporting in Help. 

Go to the next tutorial 
If you’d like to jump right in to the next tutorial, stay where you are in the main window. You’re all set to 
begin the next tutorial. Remember that you can do most of the tutorials in any order you’d like. 

Get to work on your own records 
If you feel like you don’t need any more practice and want to get to work on your own records, you just 
need to delete the practice records and you’re ready to go: 

1. Click Select, and then click All Records. 

2. Click Record, and then click Delete from All Lists. 

The Master List should now be empty.  
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